Ошибка при написании тестов


#1

{ВнешняяОбработка.bddRunner.Форма.Форма.Форма(1960)}: Неизвестный Тип: ПараметрИменованный в ПолучитьЗначениеДляПередачиВМетод
ВызватьИсключение “Неизвестный Тип: " + Тип + " в ПолучитьЗначениеДляПередачиВМетод”;

Цитата
//Дано Существуют метаданные ‘РегистрСведений.ШтатноеРасписаниеОрганизаций’
//@СуществуютМетаданные(Парам01)
Процедура СуществуютМетаданные(Парам01) Экспорт
РезультатПоиска = Метаданные.НайтиПоПолномуИмени(Парам01);
Если РезультатПоиска = Неопределено Тогда
ВызватьИсключение "Отсутствует объект метаданных " + Парам01;
КонецЕсли;
КонецПроцедуры
//И Существует запись справочника ‘Организации’, ‘Ален-Балт ООО’
//@СуществуетЗаписьСправочника(Парам01,Парам02)
Процедура СуществуетЗаписьСправочника(Парам01,Парам02) Экспорт
Сообщить(Парам01);
//Менеджер = Справочники[Парам01];
//РезультатСправочника = Менеджер.НайтиПоНаименованию(Парам02);
//Если РезультатСправочника = Неопределено Тогда
// ВызватьИсключение "Не обнаружена запись справочника " + Парам01 + " значение " + Парам02;
//КонецЕсли;
КонецПроцедуры


#2

Цитата
Функция ПолучитьЗначениеДляПередачиВМетод(Значение,Тип)
Если Тип = “Строка” Тогда
Возврат “”"" + СтрЗаменить(Значение,"""","""""") + “”"";
ИначеЕсли Тип = “Число” Тогда
Возврат Значение;
ИначеЕсли Тип = “Дата” Тогда
Возврат ПреобразоватьКДатеСтроку(Значение);
Иначе
ВызватьИсключение “Неизвестный Тип: " + Тип + " в ПолучитьЗначениеДляПередачиВМетод”;
КонецЕсли;
КонецФункции

Тип = ПараметрИменнованный ЧЕГО ОН ВЫЗЫВАЕТ ИСКЛЮЧЕНИЕ?
получается в feature файле писать так нельзя?

Цитата
И Существует запись справочника ‘ПодразделенияОрганизаций’, <Подразделение>


#3

если у вас Сценарий, а не “Структура сценария” с примерами, то нельзя.


#4

это я писал в блоке Контекст, хотя по логике должно работать, он же для всех запускается


#5

@LexX1st Внимательно прочитай это сообщений и подумай.

Скобки < и > зарезервированы для параметров исключительно в структуре сценария