ADD Обычные формы очень странное поведение

add

#1

10.10.2018 10:19:26 Шаг (И И Штатное расписание 2 Водителя в Подразделении Доставка) не реализован.
Хотя
Процедура ЗанятыеШтатныеЕдиницыОрганизацийГрузчикаВПодразделенииКомплектация(Парам01) Экспорт
** ДолжностьСсылка = Справочники.ДолжностиОрганизаций.НайтиПоКоду(“000000036”);**
** ПодразделениеСсылка = Справочники.ПодразделенияОрганизаций.НайтиПоКоду(“000000015”);**
** ЗаписьШтатногоРасписания = РегистрыСведений.ШтатноеРасписаниеОрганизаций.СоздатьМенеджерЗаписи();**
** ЗаписьШтатногоРасписания.Период = ТекущаяДата();**
** ЗаписьШтатногоРасписания.Должность = ДолжностьСсылка;**
** ЗаписьШтатногоРасписания.ПодразделениеОрганизации = ПодразделениеСсылка;**
** ЗаписьШтатногоРасписания.КоличествоСтавок = 2;**
** Попытка**
** ЗаписьШтатногоРасписания.Записать();**
** Сообщить(“Штатное расписание 2 водителя”);**
** Исключение**
** ВызватьИсключение “Не удалось создать штатное расписание.”;**
** КонецПопытки;**
КонецПроцедуры
Если я запишу следующую процедуру эта ошибка исчезнет но будет ругатся что след не реализовано.
Версия ADD последняя


#2

Можете привести полную шапку шага, которую генерирует Vanessa и вызов ДобавитьШагВМассивТестов?


#3

vanessa-behavior 5.6.0 использую из пакета ADD

//И ЗанятыеШтатныеЕдиницыОрганизаций 2 грузчика в Подразделении Комплектация
//@ЗанятыеШтатныеЕдиницыОрганизацийГрузчикаВПодразделенииКомплектация(Парам01)

Процедура ЗанятыеШтатныеЕдиницыОрганизацийГрузчикаВПодразделенииКомплектация(Парам01) Экспорт
ДолжностьСсылка = Справочники.ДолжностиОрганизаций.НайтиПоКоду(“000000036”);
ПодразделениеСсылка = Справочники.ПодразделенияОрганизаций.НайтиПоКоду(“000000015”);
ЗаписьШтатногоРасписания = РегистрыСведений.ШтатноеРасписаниеОрганизаций.СоздатьМенеджерЗаписи();
ЗаписьШтатногоРасписания.Период = ТекущаяДата();
ЗаписьШтатногоРасписания.Должность = ДолжностьСсылка;
ЗаписьШтатногоРасписания.ПодразделениеОрганизации = ПодразделениеСсылка;
ЗаписьШтатногоРасписания.КоличествоСтавок = 2;
Попытка
ЗаписьШтатногоРасписания.Записать();
Сообщить(“Штатное расписание 2 водителя”);
Исключение
ВызватьИсключение “Не удалось создать штатное расписание.”;
КонецПопытки;
КонецПроцедуры
////////////////////////////////////////////////
Функция ПолучитьСписокТестов(КонтекстФреймворкаBDD) Экспорт
Ванесса = КонтекстФреймворкаBDD;

ВсеТесты = Новый Массив;

//описание параметров
//пример вызова Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,Снипет,ИмяПроцедуры,ПредставлениеТеста,ОписаниеШага,ТипШага,Транзакция,Параметр);

Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"РегистрСведенийШтатноеРасписаниеОрганизаций()","РегистрСведенийШтатноеРасписаниеОрганизаций","Дано Регистр сведений ШтатноеРасписаниеОрганизаций","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ДокументПриемНаРаботуВОрганизацию()","ДокументПриемНаРаботуВОрганизацию","И Документ ПриемНаРаботуВОрганизацию","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ДокументКадровоеПеремещениеОрганизаций()","ДокументКадровоеПеремещениеОрганизаций","И Документ КадровоеПеремещениеОрганизаций","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"РегистрНакопленияЗанятыеШтатныеЕдиницыОрганизаций()","РегистрНакопленияЗанятыеШтатныеЕдиницыОрганизаций","И Регистр накопления ЗанятыеШтатныеЕдиницыОрганизаций","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ШтатноеРасписаниеГрузчикаВПодразделенииКомплектация(Парам01)","ШтатноеРасписаниеГрузчикаВПодразделенииКомплектация","И Штатное расписание 3 грузчика в Подразделении Комплектация","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ЗанятыеШтатныеЕдиницыОрганизацийГрузчикаВПодразделенииКомплектация(Парам01)","ЗанятыеШтатныеЕдиницыОрганизацийГрузчикаВПодразделенииКомплектация","И ЗанятыеШтатныеЕдиницыОрганизаций 2 грузчика в Подразделении Комплектация","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ИШтатноеРасписаниеВодителяВПодразделенииДоставка(Парам01)","ИШтатноеРасписаниеВодителяВПодразделенииДоставка","И И Штатное расписание 2 Водителя в Подразделении Доставка","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ЗанятыеШтатныеЕдиницыОрганизацийВодителяВПодразделенииДоставка(Парам01)","ЗанятыеШтатныеЕдиницыОрганизацийВодителяВПодразделенииДоставка","И ЗанятыеШтатныеЕдиницыОрганизаций 2 Водителя в Подразделении Доставка","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ЯВвожуДокумент(Документ)","ЯВвожуДокумент","Когда я ввожу документ <Документ>","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ЯУказалОрганизациюВШапкеДокумента()","ЯУказалОрганизациюВШапкеДокумента","И я указал Организацию в шапке документа","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ДобавилСтрокуВТабличнуюЧастьРаботникиОрганизации()","ДобавилСтрокуВТабличнуюЧастьРаботникиОрганизации","И Добавил строку в табличную часть РаботникиОрганизации","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"Указал(Подразделение)","Указал","И указал <Подразделение>","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ПолучилШтатноеРасписание(СтавокРасписания)","ПолучилШтатноеРасписание","И получил штатное расписание <СтавокРасписания>","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ПолучилЗанятыхШтатныхЕдиниц(СтавокЗанято)","ПолучилЗанятыхШтатныхЕдиниц","И получил занятых штатных единиц <СтавокЗанято>","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ИметсяСвободнаяШтатнаяЕдиница()","ИметсяСвободнаяШтатнаяЕдиница","И имется свободная штатная единица","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"СтатусДокумента(ДокументПроведен)","СтатусДокумента","Тогда статус документа <ДокументПроведен>","","");

Возврат ВсеТесты;

КонецФункции


#4

Меня смущает что ругается с 2 и

И И Штатное расписание 2 Водителя в Подразделении Доставка

У вас ругается на Доставка а вы привели процедуру с подразделением Комплектация.


#5

Да это я сам уже заметил, но суть не меняет вопроса, на предыдущих шагах ситуация была так как описано в шапке темы.


#6

Так приведите реализацию шага ЗанятыеШтатныеЕдиницыОрганизацийВодителяВПодразделенииДоставка(Парам01)


#7

#encoding: utf-8
#language: ru

Функционал: Контроль превышения штатного расписания
Как Менеджер по персоналу
Я хочу в документе ПриемНаРаботуВОрганизацию И КадровоеПеремещениеОрганизаций
Чтобы при проведении происходил отказ при привышении штатного расписания

Контекст
Дано Существуют метаданные ‘РегистрСведений.ШтатноеРасписаниеОрганизаций’
И Существуют метаданные ‘РегистрНакопления.ЗанятыеШтатныеЕдиницыОрганизаций’
И Существует запись справочника ‘Организации’, ‘Ален-Балт ООО’
И Существует запись справочника ‘ДолжностиОрганизаций’, ‘Грузчик’

Структура сценария: Сценарий ПриемНаРаботуВОрганизацию
Когда я ввожу новый документ ‘ПриемНаРаботуВОрганизацию’
И указал организацию
И указал дату документа <ДатаПриема>
И Добавил строку в табличную часть РаботникиОрганизации
И указал сотрудника <Сотрудник>
И указал должность
И указал подразделение <Подразделение>
И указал количество ставок <ЗанимаемыхСтавок>
И указал график работы
И указал Дату приема <ДатаПриема>
И получил штатное расписание
И получил занятых штатных единиц
И занимаемых ставок плюс занятых штатных единиц меньше или равно расписанию
Тогда проведение документа <ДокументПроведен>

Примеры:
|Сотрудник | Подразделение | ЗанимаемыхСтавок | ДатаПриема | ДокументПроведен |
|Иванов Иван Иванович | Распределительный центр | 1 | 09.10.2018 | Истина |
|Иванов Иван Иванович | Распределительный центр | 1 | 09.10.2018 | Ложь |


#8

///////////////////////////////////////////////////
//Служебные функции и процедуры
///////////////////////////////////////////////////

// контекст фреймворка Vanessa-Behavior
Перем Ванесса;

// Функция экспортирует список шагов, которые реализованы в данной внешней обработке.
Функция ПолучитьСписокТестов(КонтекстФреймворкаBDD) Экспорт
Ванесса = КонтекстФреймворкаBDD;

ВсеТесты = Новый Массив;

//описание параметров
//пример вызова Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,Снипет,ИмяПроцедуры,ПредставлениеТеста,ОписаниеШага,ТипШага,Транзакция,Параметр);

Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"СуществуютМетаданные(Парам01)","СуществуютМетаданные","Дано Существуют метаданные 'РегистрСведений.ШтатноеРасписаниеОрганизаций'","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"СуществуетЗаписьСправочника(Парам01,Парам02)","СуществуетЗаписьСправочника","И Существует запись справочника 'Организации', 'Ален-Балт ООО'","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ЯВвожуНовыйДокумент(Парам01)","ЯВвожуНовыйДокумент","Когда я ввожу новый документ 'ПриемНаРаботуВОрганизацию'","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"УказалОрганизацию()","УказалОрганизацию","И указал организацию","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"УказалДатуДокумента(ДатаПриема)","УказалДатуДокумента","И указал дату документа <ДатаПриема>","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ДобавилСтрокуВТабличнуюЧастьРаботникиОрганизации()","ДобавилСтрокуВТабличнуюЧастьРаботникиОрганизации","И Добавил строку в табличную часть РаботникиОрганизации","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"УказалСотрудника(Сотрудник)","УказалСотрудника","И указал сотрудника <Сотрудник>","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"УказалДолжность()","УказалДолжность","И указал должность","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"УказалПодразделение(Подразделение)","УказалПодразделение","И указал подразделение <Подразделение>","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"УказалКоличествоСтавок(ЗанимаемыхСтавок)","УказалКоличествоСтавок","И указал количество ставок <ЗанимаемыхСтавок>","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"УказалГрафикРаботы()","УказалГрафикРаботы","И указал график работы","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"УказалДатуПриема(ДатаПриема)","УказалДатуПриема","И указал Дату приема <ДатаПриема>","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ПолучилШтатноеРасписание()","ПолучилШтатноеРасписание","И получил штатное расписание","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ПолучилЗанятыхШтатныхЕдиниц()","ПолучилЗанятыхШтатныхЕдиниц","И получил занятых штатных единиц","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ЗанимаемыхСтавокПлюсЗанятыхШтатныхЕдиницМеньшеИлиРавноРасписанию()","ЗанимаемыхСтавокПлюсЗанятыхШтатныхЕдиницМеньшеИлиРавноРасписанию","И занимаемых ставок плюс занятых штатных единиц меньше или равно расписанию","","");
Ванесса.ДобавитьШагВМассивТестов(ВсеТесты,"ПроведениеДокумента(ДокументПроведен)","ПроведениеДокумента","Тогда проведение документа <ДокументПроведен>","","");

Возврат ВсеТесты;

КонецФункции

// Служебная функция для подключения библиотеки создания fixtures.
Функция ПолучитьМакетОбработки(ИмяМакета) Экспорт
Возврат ПолучитьМакет(ИмяМакета);
КонецФункции

///////////////////////////////////////////////////
//Работа со сценариями
///////////////////////////////////////////////////

// Процедура выполняется перед началом каждого сценария
Процедура ПередНачаломСценария() Экспорт

КонецПроцедуры

// Процедура выполняется перед окончанием каждого сценария
Процедура ПередОкончаниемСценария() Экспорт

КонецПроцедуры

///////////////////////////////////////////////////
//Реализация шагов
///////////////////////////////////////////////////

//Дано Существуют метаданные ‘РегистрСведений.ШтатноеРасписаниеОрганизаций’
//@СуществуютМетаданные(Парам01)
Процедура СуществуютМетаданные(Парам01) Экспорт
РезультатПоиска = Метаданные.НайтиПоПолномуИмени(Парам01);
Если РезультатПоиска = Неопределено Тогда
ВызватьИсключение "Отсутствует объект метаданных " + Парам01;
КонецЕсли;
КонецПроцедуры

//И Существует запись справочника ‘Организации’, ‘Ален-Балт ООО’
//@СуществуетЗаписьСправочника(Парам01,Парам02)
Процедура СуществуетЗаписьСправочника(Парам01,Парам02) Экспорт
Менеджер = Справочники[Парам01];
РезультатСправочника = Менеджер.НайтиПоНаименованию(Парам02);
Если РезультатСправочника = Менеджер.ПустаяСсылка() Тогда
ВызватьИсключение "Не обнаружена запись справочника " + Парам01 + " значение " + Парам02;
КонецЕсли;
Контекст.Вставить(Парам01, РезультатСправочника);
КонецПроцедуры

//Когда я ввожу новый документ ‘ПриемНаРаботуВОрганизацию’
//@ЯВвожуНовыйДокумент(Парам01)
Процедура ЯВвожуНовыйДокумент(Парам01) Экспорт
НовыйКадровыйДокумент = Документы[Парам01].СоздатьДокумент();
Контекст.Вставить(“НовыйКадровыйДокумент”, НовыйКадровыйДокумент);
КонецПроцедуры

//И указал организацию
//@УказалОрганизацию()
Процедура УказалОрганизацию() Экспорт
Организация = Контекст.Организации;
ДокументОбъект = Контекст.НовыйКадровыйДокумент;
ДокументОбъект.Организация = Организация;
КонецПроцедуры

//И Добавил строку в табличную часть РаботникиОрганизации
//@ДобавилСтрокуВТабличнуюЧастьРаботникиОрганизации()
Процедура ДобавилСтрокуВТабличнуюЧастьРаботникиОрганизации() Экспорт
ДокументОбъект = Контекст.НовыйКадровыйДокумент;
ЗаписьРаботник = ДокументОбъект.РаботникиОрганизации.Добавить();
Контекст.Вставить(“ЗаписьРаботник”, ЗаписьРаботник);
КонецПроцедуры

//И указал сотрудника <Сотрудник>
//@УказалСотрудника(Сотрудник)
Процедура УказалСотрудника(Сотрудник) Экспорт
Запрос = Новый Запрос;
Запрос.Текст =
“ВЫБРАТЬ
| СотрудникиОрганизаций.Ссылка
|ИЗ
| Справочник.СотрудникиОрганизаций КАК СотрудникиОрганизаций
|ГДЕ
| СотрудникиОрганизаций.Организация = &Организация
| И СотрудникиОрганизаций.Наименование = &Наименование”;

Запрос.УстановитьПараметр("Наименование", Сотрудник);
Запрос.УстановитьПараметр("Организация", Контекст.Организации);

РезультатЗапроса = Запрос.Выполнить();
Если РезультатЗапроса.Пустой() Тогда
	ВызватьИсключение "Не найден сотрудник.";
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
ВыборкаДетальныеЗаписи.Следующий();
СсылкаСотрудник = ВыборкаДетальныеЗаписи.Ссылка;
ЗаписьРаботник = Контекст.ЗаписьРаботник;
ЗаписьРаботник.Сотрудник = СсылкаСотрудник;

КонецПроцедуры

//И указал подразделение <Подразделение>
//@УказалПодразделение(Подразделение)
Процедура УказалПодразделение(Подразделение) Экспорт
ДокументОбъект = Контекст.НовыйКадровыйДокумент;
СсылкаПодразделение = Справочники.ПодразделенияОрганизаций.НайтиПоНаименованию(Подразделение, ДокументОбъект.Организация);
Если СсылкаПодразделение = Справочники.ПодразделенияОрганизаций Тогда
ВызватьИсключение "Не существует подразделения " + Подразделение;
КонецЕсли;
ЗаписьРаботник = Контекст.ЗаписьРаботник;
ЗаписьРаботник.ПодразделениеОрганизации = СсылкаПодразделение;
КонецПроцедуры

//И указал количество ставок <ЗанимаемыхСтавок>
//@УказалКоличествоСтавок(ЗанимаемыхСтавок)
Процедура УказалКоличествоСтавок(ЗанимаемыхСтавок) Экспорт
ЗаписьРаботник = Контекст.ЗаписьРаботник;
ЗаписьРаботник.ЗанимаемыхСтавок = ЗанимаемыхСтавок;
КонецПроцедуры

//И указал Дату приема <ДатаПриема>
//@УказалДатуПриема(ДатаПриема)
Процедура УказалДатуПриема(ДатаПриема) Экспорт
ЗаписьРаботник = Контекст.ЗаписьРаботник;
ЗаписьРаботник.ДатаПриема = ДатаПриема;
КонецПроцедуры

//И получил штатное расписание
//@ПолучилШтатноеРасписание()
Процедура ПолучилШтатноеРасписание() Экспорт
ЗаписьРаботник = Контекст.ЗаписьРаботник;
Запрос = Новый Запрос;
Запрос.Текст =
“ВЫБРАТЬ РАЗРЕШЕННЫЕ
| ШтатноеРасписаниеОрганизацийСрезПервых.КоличествоСтавок
|ИЗ
| РегистрСведений.ШтатноеРасписаниеОрганизаций.СрезПоследних(
| &ДатаСреза,
| Должность = &Должность
| И ПодразделениеОрганизации = &Подразделение) КАК ШтатноеРасписаниеОрганизацийСрезПервых”;
Запрос.УстановитьПараметр(“ДатаСреза”, ЗаписьРаботник.ДатаПриема);
Запрос.УстановитьПараметр(“Должность”, ЗаписьРаботник.Должность);
Запрос.УстановитьПараметр(“Подразделение”, ЗаписьРаботник.ПодразделениеОрганизации);

РезультатЗапроса = Запрос.Выполнить();
Если РезультатЗапроса.Пустой() Тогда
	ВызватьИсключение "Не получено штатное расписание.";
КонецЕсли;
Выборка = РезультатЗапроса.Выбрать();
Выборка.Следующий();
Контекст.Вставить("КоличествоСтавок", Выборка.КоличествоСтавок);

КонецПроцедуры

//И получил занятых штатных единиц
//@ПолучилЗанятыхШтатныхЕдиниц()
Процедура ПолучилЗанятыхШтатныхЕдиниц() Экспорт
ЗаписьРаботник = Контекст.ЗаписьРаботник;
Запрос = Новый Запрос;
Запрос.Текст =
“ВЫБРАТЬ РАЗРЕШЕННЫЕ
| ЗанятыеШтатныеЕдиницыОрганизацийОстатки.КоличествоСтавокОстаток
|ИЗ
| РегистрНакопления.ЗанятыеШтатныеЕдиницыОрганизаций.Остатки(
| &ДатаСреза,
| Должность = &Должность
| И ПодразделениеОрганизации = &Подразделение) КАК ЗанятыеШтатныеЕдиницыОрганизацийОстатки”;

Запрос.УстановитьПараметр("ДатаСреза", ЗаписьРаботник.ДатаПриема);
Запрос.УстановитьПараметр("Должность", ЗаписьРаботник.Должность);
Запрос.УстановитьПараметр("Подразделение", ЗаписьРаботник.ПодразделениеОрганизации);

РезультатЗапроса = Запрос.Выполнить();
Если РезультатЗапроса.Пустой() Тогда
	ВызватьИсключение "Не получено количество занятых единиц.";
КонецЕсли;
Выборка = РезультатЗапроса.Выбрать();
Выборка.Следующий();
Контекст.Вставить("КоличествоСтавокОстаток", Выборка.КоличествоСтавокОстаток);

КонецПроцедуры

//Тогда проведение документа <ДокументПроведен>
//@ПроведениеДокумента(ДокументПроведен)
Процедура ПроведениеДокумента(ДокументПроведен) Экспорт
ДокументОбъект = Контекст.НовыйКадровыйДокумент;
ДокументОбъект.Записать(РежимЗаписиДокумента.Проведение);
Если Не ДокументОбъект.Проведен = ДокументПроведен Тогда
ВызватьИсключение “Условие проведения не выполнено.”;
КонецЕсли;
КонецПроцедуры

//И указал должность
//@УказалДолжность()
Процедура УказалДолжность() Экспорт
Должность = Контекст.ДолжностиОрганизаций;
РезультатДолжность = Справочники.ДолжностиОрганизаций.НайтиПоНаименованию(Должность);
Если РезультатДолжность = Неопределено Тогда
ВызватьИсключение “Должность отсутствует в справочнике”;
КонецЕсли;
ЗаписьРаботник = Контекст.ЗаписьРаботник;
ЗаписьРаботник.Должность = РезультатДолжность;
КонецПроцедуры

//И занимаемых ставок плюс занятых штатных единиц меньше или равно расписанию
//@ЗанимаемыхСтавокПлюсЗанятыхШтатныхЕдиницМеньшеИлиРавноРасписанию()
Процедура ЗанимаемыхСтавокПлюсЗанятыхШтатныхЕдиницМеньшеИлиРавноРасписанию() Экспорт
Если Не Контекст.КоличествоСтавокОстаток + Контекст.ЗаписьРаботник.ЗанимаемыхСтавок <= Контекст.КоличествоСтавок Тогда
ВызватьИсключение “Отсутствуют свободные штатные единицы.”;
КонецЕсли;
КонецПроцедуры

//И указал дату документа <ДатаПриема>
//@УказалДатуДокумента(ДатаПриема)
Процедура УказалДатуДокумента(ДатаПриема) Экспорт
ДокументОбъект = Контекст.НовыйКадровыйДокумент;
ДокументОбъект.Дата = ДатаПриема;
КонецПроцедуры

//И указал график работы
//@УказалГрафикРаботы()
Процедура УказалГрафикРаботы() Экспорт
РезультатГрафик = Справочники.ГрафикиРаботы.НайтиПоНаименованию(“пятидневка”);
Если РезультатГрафик = Справочники.ГрафикиРаботы.ПустаяСсылка() Тогда
ВызватьИсключение “Не найден график работы.”;
КонецЕсли;
ЗаписьРаботник = Контекст.ЗаписьРаботник;
ЗаписьРаботник.ГрафикРаботы = РезультатГрафик;
КонецПроцедуры


#9

11.10.2018 16:17:16 Работаю по сценарию: Сценарий ПриемНаРаботуВОрганизацию (Пример №1)
11.10.2018 16:17:16 Не реализован. Пустой адрес снипета у шага: Дано Существуют метаданные ‘РегистрСведений.ШтатноеРасписаниеОрганизаций’

11.10.2018 16:17:16 Работаю по сценарию: Сценарий ПриемНаРаботуВОрганизацию (Пример №2)
11.10.2018 16:17:16 Не реализован. Пустой адрес снипета у шага: Дано Существуют метаданные ‘РегистрСведений.ШтатноеРасписаниеОрганизаций’

11.10.2018 16:17:17 Все сценарии обработаны!

Шикарное поведение


#10

Твоя обработка проходит синтакс-контроль в конфигураторе?
при открытии обработки ошибок не вываливается случайно?


#11

я уже понял что нарвался на глюк непосредственно платформы, благодарю, после перезагрузки конфигуратора и проверки кода нашел не закрытое если.