How-to xDrivenDevelopment - как использовать и как работать


#1

В рамках GITHUB репозиториев сосредоточены и развиваются инструменты для промышленной разработки на платформе 1С.

Но однако-же не секрет, что НЕ все можно обсудить в рамках задач Github

Поэтому если у Вас есть вопросы, по использованию, а также по текущей документации WIKI - задавайте ваши вопросы, делитесь особенностями использования. Расскажите о своих fork’ах

P.S. Если вы не знаете, что такое fork - это тоже можно спросить здесь


#2

Эта тема теперь прилеплена глобально и будет появляться вверху списка тем соответствующего раздела и всех списков тем, пока персонал не отлепит ее глобально или пользователь не отлепит лично для себя.


#3

Отладка в управляемом режиме

Отладка теста для управляемой формы, к сожалению, не так проста как для толстого клиента. Можно разделить даже на несколько способов:

  1. Диагностические сообщения или же запись в журнал регистрации: данный способ чаще применяешь при активной разработке, еще помнишь/знаешь что должно упасть и своими сообщениями пытаешься угадать.

  2. Запуск тестовой обработки в безопасном режиме: в основном подходит для мелких обработок, не использующих ни файловую систему, ни COM соединения, “не интеграционных тестов”

  3. Добавление на форму кнопки и ручное выполнение кода теста: самое привычное решение, но к сожалению применимо на этапе написания теста, т.к. еще можно отказаться от полезных мелочей типа “юТест”. Что-бы получить заветную переменную юТест достаточно в команде вызова теста вставить такой код:

    Для каждого Окн Из Окна Цикл
    Если ТипЗнч(Окн) = Тип("ОкноКлиентскогоПриложения") Тогда
        Если Найти(Строка(Окн.Заголовок), "xUnitFor1C")>0 Тогда
            ФормуНашли = Истина;
            ФормаxUnitFor1c = Окн.ПолучитьСодержимое();
        КонецЕсли;
       КонецЕсли;
    КонецЦикла;
    
    Если ФормуНашли Тогда
    
        МассивТестов = ПолучитьСписокТестов(ФормаxUnitFor1c);
        Тест_ПроверитьРавно();
    
    КонецЕсли;
    

Где “Тест_ПроверитьРавно()” и есть необходимая процедура для отладки.


#4

Более подробно можно посмотреть на видео-примере


#5

Хотелось бы услышать рекомендации про хорошие книжки, рассказываю как лучше использовать TDD, когда они применимы, технику их написания и т.п.
Кто-нибудь поделиться? Можно (даже нужно) англоязычные, если русских аналогов нет.

нет ничего более практичного, чем хорошая теоретическая подготовка.


#6

скопировал

Литература/материалы для самостоятельного изучения

a. Википедия - Разработка через тестирование

b. К.Бек. Экстремальное программирование: разработка через тестирование

c. Р.С.Мартин. Чистый код

d. М.Фаулер. Рефакторинг - улучшение существующего кода

e. С.Макконнел. Совершенный код

f. Р.С.Мартин, М.Мартин. Принципы, паттерны и методики гибкой разработки на языке C#

http://infostart.ru/public/328695/

А также мы тут активно BDD настраиваем поэтому советуем последнюю интересную книгу на английском

BDD In Action от John Ferguson Smart