Служба RAS запускается и сразу останавливается


#1

Добрый день.
помогите, пожалуйста с такой проблемой.
Создал службу ras такой командой
sc create "1C:Enterprise RAS" binpath= "\"C:/Program Files/1cv8/8.3.10.2466/bin/ras.exe\" cluster --service --port=1545 localhost:1540"

Затем запускаю ее из списка служб, она запускается и сразу гасится.
serviceRAS

агент сервера 1С крутится на localhost:1540, там же где и службу запускаю

Как победить эту проблему?


#2

А что с брэндмауером?
В смысле проверь порты.


#3

проверить 1545?
а какие виды разрешений должны быть?


#4

Для начала, просто отключи брэндмауер и помотри взлетает или нет.


#5

Брендмауер был отключен. Я еще и службу остановил.
Но моя служба все равно запускается и гасится сразу


#6

На всякий случай: А сервер 1С на той же машине крутится на порту 1540?


#7

Еще бывает беда с правами. Возможно не хватает прав на рабочие каталоги или какие-то файлы у пользователя, под которым стартует служба


#8

Да там вроде RAS ничего не использует, а если бы на каталог 1С прав не было, ругалось бы по другому.


#9

Да агент сервера 1С на порту 1540 крутится и той же версии


#10

Я бы посмотрел под каким пользователем пытается запуститься служба, и на права этого пользователя.


#11

Т.к. sc запускалось без пользователя, там должен быть Local System.


#12

да именно так: “Системная учетная запись”

Админы сказали что запуск и остановка службы происходили в штатном режиме. В логах они не нашли никаких ошибок.

Говорят, что какая то другая служба гасит мою службу или конфликтует.


#13

netstat -an
1545 может быть занят.


#14

там есть такая строка
UDP [::]:1545 *:*
Эм. а как понять что он занят?
можно ли посмотреть только его ?


#15

а добавь b: netstat -anb
там будет еще исполняемый файл


#16

listen написано?


#17

Еще можно проверить запускается ли ras из командной строки.


#18

эта команда показала, что исполняемый файл на порту 1545 это 1cv8.exe
Значит порт занят.
Пересоздал службу на порту 15450
Служба запустилась
Но теперь проверка не работает
"C:/Program Files/1cv8/8.3.10.2466/bin/ras.exe" cluster list localhost:15450
выдает ошибку соединения с сервером


вариант проверки по ip я там ошибся одной цифрой, теперь и по ip выдает одну строку “ошибка соединения с кластером серверов”


#19

из командной строки запускается на порту 15450, 15451 дальше не проверял


#20

Все заработало, публиковал службу на другой ip.
Всем огромное спасибо!!
Ваши подсказки навели на нужное решение.